Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Baumstrukturmodus | Linearer Modus
WENN funktion und SVERWEIS verbinden? - sverweis mit wenn funktion
18-11-2005, 10:33
Beitrag: #1
WENN funktion und SVERWEIS verbinden? - sverweis mit wenn funktion
hai...

ich mache gerade ne tabelle wo aufgelistet werden soll, wo die thin clients von mir stehen, und wie sie heißen und so...

da wollte ich mir dann für die tabelle nen reiter machen, wo man einfach nach den dingern suchen kann, wenn man einfach eingibt wie das ding heißt.

jetzt habe ich folgende probleme...

wenn ich nichts in das eingabefeld schreibe, steht in den feldern mit der sverweis-formel "#NA" , ist ja auch logisch, aber kann ich das irgendwie mit nem wenn-befehl wegmachen?

und...

wenn in der tabelle mit den daten mal ein feld leer ist, dann schreibt er bei dem sverweis ne "0", wie kann ich die wegmachen?

wäre sehr nett wenn ihr mir helfen könntet.

danke schonmal im vorraus

www.Nirvana-Rulez.de
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18-11-2005, 13:11
Beitrag: #2
WENN funktion und SVERWEIS verbinden? - sverweis mit wenn funktion
Du brauchst nur abfragen ob die Zelle leer ist.

WENN(A1="";"";SVERWEIS(....))

Hier fragt WENN ab ob die Zelle A1 etwas enthält. Nach dem ersten Semikolon sind nur Anführungs- und Ausführungsstriche, zwischen denen nichts steht. Wenn also A1 nichts enthält, soll auch nichts ausgegeben werden. Somit würde dein #NA nicht erscheinen.

Nach dem 2. Semikolon steht dann der SVERWEIS, der dann abgearbeitet wird wenn die Zelle A1 etwas enthält.

In ähnlicher Weise machst du das mit WENN(A1=0.... .

:angry:
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18-11-2005, 15:39
Beitrag: #3
WENN funktion und SVERWEIS verbinden? - sverweis mit wenn funktion
hai geht schonmal danke... jetzt kommen aber weitere fragen... habe jetzt schon lange nach ner lösung gesucht, aber... ich kriege es nicht hin.

1. wenn ich bei dem feld für das suchkriterium einen namen reinschreibe den es nicht gibt, wird mir wieder "#NA" angezeigt... kann ich das wegmachen?

2. und... weil es mehrere geräte sind, habe ich für alle spalten die markierung von zelle 2 bis 999 gewählt. (z.b. D2:D999) also sieht der wenn-befehl so aus:

Code:
WENN('VNC Liste'!D2:D999="";"";SVERWEIS...

wenn jetzt aber in irgendeiner zelle zwischen D2 und D999 steht, dann schreibt er mir wenn ich ein suchkriterium eingebe wo da nichts stehen soll, wieder "#NA" rein.

ich hoffe mir kann einer helfen (auch wenn mir nicht zu helfen ist(schlechter witz... sorry macht die arbeit))

danke schonmal im vorraus

www.Nirvana-Rulez.de
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Tags
sverweis mit wenn funktion, wenn funktion mit sverweis, sverweis und wenn funktion kombinieren, wenn mit sverweis kombinieren, sverweis in wenn funktion, sverweis wenn, sverweis und wenn funktion verknüpfen, wenn funktion mit sverweis verknüpfen, wenn funktion mit sverweis verknüpfen, sverweis mit wenn funktion, sverweis mit wenn funktion, wenn funktion mit sverweis verknüpfen, sverweis mit wenn funktion, sverweis und wenn funktion kombinieren, wenn funktion mit sverweis verknüpfen, sites
« Ein Thema zurück | Ein Thema vor »
Antwort schreiben 


  • Druckversion anzeigen
  • Thema einem Freund senden
  • Thema abonnieren
Gehe zu:




Kontakt | Windows Forum | Nach oben | Zum Inhalt | Archiv-Modus | RSS-Synchronisation| Impressum